This topic is now archived and is closed to further replies.

G27 problems. Help appreciated

1 post in this topic

So I've been using this wheel for quite som time now and has worked flawlessly.

But a week ago suddenly Logitech Gaming Software wouldn't pop up when I clicked it. So I did my standard procedure and re-installed drivers and software, tried older ones etc. Still wouldn't pop up. Well I could still change wheel settings via the Control Panel so I didn't mind not being able to access Logitech Profiler.

Now more problems started popping up, all after I drove for 2hrs in rFactor pretty intense (still learning so there was many violent wheel turns to save the car from crashing sometime) and everything was ok after that. Then I jumped in Richard Burns Rally and the steering didn't work, so I went into the settings to remap everything. Pedals, shifter was mapable, but the steering axis wouldn't get recognized.

So I did the standard procedure again, changing USB ports, reinstalling and updating and downgrading firmware. Still nothing. So now I'm stuck with that.

rFactor still worked. But now I got this weird problem where there is this massive deadzone except in a spot which is like 5 degrees. Here is a video showing it:

Help is much much appreciated.

Regards, Christian.

Share this post

Link to post
Share on other sites