Archived

This topic is now archived and is closed to further replies.

T300 RS GT sleep mode

1 post in this topic

Hi,

I have had a T300 RS GT for about 12 months and since day one I have had a couple of issues.

1. Every so often when I start a game the wheel no longer works. If I open joycpl to look at connected devices the wheel is still shown as connected but when I move the wheel/pedals there is no movement. The only way I have found to fix this is to reboot the PC and then it is OK. This seems to happen most often if I have been using the computer but not the wheel and it is as if the wheel has gone to sleep (Just a guess but that is what it seems like)

2. The other issue is that sometimes during use it starts making a very load squealing noise. Not the cooling fan as I know this sound but this is a very load piercing squealing noise.

 

I have tried contacting Thrustmaster support but they are no help whatsoever and give me the usual suggestions (Have you installed the latest drivers, have you tried unplugging the wheel)

Any help much appreciated as it is great when it is working but I must admit I was hoping for something a bit more reliable for the cost.

 

Thank you

Share this post


Link to post
Share on other sites