Dirt Rally closes itself after splash logo
0

3 posts in this topic

I've tried verification cache of files and this:

Quote

Posted December 25, 2018 Its a cpu problem. game cant run on more than 4 cores. It a problem if you have a processor with hyperthreading that has essentially 8 cores (4 virtual ones).

 

To fix this u have to find your hardware_settings_config.xml file. My save file vas in my documents/my games/dirt rally/hardwaresettings/ Open this file with notepad and replace lines of code from <cpu> to <cpu> with this:

<cpu> <restrict_if name="cores" op="int_eq" value="4"> <restrict_add> <threadStrategy workerMapFile="system/workerMap4Core.xml" forceFeedbackProcessor="3" dvdStorageProcessor="3" dataSetMonitorProcessor="1" renderProcessor="0" updateProcessor="2" fileStreamProcessor="3" /> </restrict_add> </restrict_if> <threadStrategy workerMapFile="system/workerMap4Core.xml" forceFeedbackProcessor="3" dvdStorageProcessor="3" dataSetMonitorProcessor="1" renderProcessor="0" updateProcessor="2" fileStreamProcessor="3" /> </cpu>

Save the file and run the game. This will force the game to run only on 4 cores. Cheers 😃

Doesn't work. Any ideas? Computer is a 3950X with 1660 super Windows 10 LTSC Enterprise 1809.

Edited by dukenukem

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
0