Fanatec CSL Elite Red Blink no motor movement

1 post in this topic

Hey guys,

My 6 month old CSL Elite wheel base (PS4 + PC version) is having an issue. I am getting a red blinking mode light with the 3 yellow lights on left. I have seen the fixes for blowing air in the hole to clean the wheel the sensor reads and I have tried that with no luck. Some have said it can be the sensor itself but in my case the motor doesn't even move the wheel on start up (see video). It is on the latest firmware and I have tried to flash and reinstall the firmware and there was no change. Fanatec is slow in responding, it has taken them 2 days just to respond once with some generic fixes I already did.  The US contact number is a bust with no one answering or returning my messages. Any ideas for 3 yellow lights with no motor movement?


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now