TH8A Shifter Issues
4 4

11 posts in this topic

Hi everyone. First time poster here so I hope I'm posting in the right place. The issue I have is the 9 pin connector has slowly got worse over time and has completely failed now. I want to cut out the connectors and solder the shifter wires to the usb cable. I found a couple of wiring diagrams online but I can't make any sense of them. Is there anyone that's done this before that can put this into layman's terms for me? I just need to know what colour wires to match up otherwise I'm going to have to fork out £170 for a whole new shifter.

Share this post


Link to post
Share on other sites
2 hours ago, burgerbait said:

Hi everyone. First time poster here so I hope I'm posting in the right place. The issue I have is the 9 pin connector has slowly got worse over time and has completely failed now. I want to cut out the connectors and solder the shifter wires to the usb cable. I found a couple of wiring diagrams online but I can't make any sense of them. Is there anyone that's done this before that can put this into layman's terms for me? I just need to know what colour wires to match up otherwise I'm going to have to fork out £170 for a whole new shifter.

Hello.

I believe the wires are with own collors - so collor to collor will be no brainer!;)

Share this post


Link to post
Share on other sites

I have kind of an off topic question. The 9-pin you're talking about is the connection between the shifter and the cable of choice that you're using (USB or DIN), right. So the question is how did it get messed up?

I know this question doesn't help with the problem, although it might once I understand what lead to the problem. I'm just curious how it got to this.

 

One other thing; which side of the 9-pin is going bad? The shifter side or the cable side or both.

Edited by Wolf68k

Share this post


Link to post
Share on other sites

Thanks for the replies guys. I have tried matching the coloured wires up and soldering them together but when I plugged it into the pc it said usb device not recognised. I've tried a couple other wire combinations that have been suggested in other forums but had no luck. Wolf, you're right in thinking it's the 9pin connection between the shifter and the usb/din. I think it's just got messed up over time as I've been swapping between the usb cable and the din cable. I have been playing on pc as well as Xbox. I determined that the issue was on the shifter side before I cut up the wires because it wouldn't work with the usb cable or the din cable. I thought it would be unlikely for both the cables to fail at the same rate so I assumed it was the shifter side that was causing the issue. 

Share this post


Link to post
Share on other sites

I've had two TH8A Shifters go bad this way. I think it's a problem with the shorter cable that comes out of the shifter. Maybe a wire is breaking somewhere near the unit's body, or more likely, I think it's just above the heavy-duty threaded coupling. I would often change my setup according to what sim and car I was driving, and I would sometimes switch cables from USB to the wheel connection for console racing. I was often unthreading and re-threading together that coupling. I think this shortens the life of that cable.

If it's no longer under warranty, you might contact Thrustmaster to see if they'll sell you a new cable with the Hall sensor board attached to it. Very likely they'll still want your serial number before agreeing to sell you anything.

I solved my problem by switching over to the Fanatec Clubsport SQ v1.5 shifter a few weeks ago. I still like the TH8A (I own three now--one is dead, one is faulty), but I think the Fanatec is worth the additional cost if it's in your budget. Easily moving a slider, and switching out nicely machined knobs to change modes (instead of having to partially take it apart, or buy a second unit) is what clinched the deal/decision for me.

Edited by ApexVGear

Share this post


Link to post
Share on other sites

Hi burgerbait! 

Of course color matched cable wont work.

Long time ago I open up my th8a and drawed a pin assigment. Here you are my attachement. 

58c6a010ada13_Sifterportpinout.jpg.c8a737900d779f644f063ce7ec3efd94.jpg2.thumb.png.47030cad945e9524b056cb0cae54b8d1.png1.thumb.png.40187fbe9f0ad06886f4be005719c731.pngDSC_3128.thumb.JPG.b0f3b7c9286f60e5898a0095409be3c7.JPG

Maybe this helps. If not ask accordingly. 

Steve

Share this post


Link to post
Share on other sites

Thanks for the help guys. The diagrams posted above are the one I found on other forums. I tried to get it sorted again tonight but I can't seem to make any sense of it. I tried matching wires 8 4 5 1 from inside the shifter with the correct wires on the usb cable and had no luck. I thought that maybe I had the wires on the usb the wrong way around so I tried reversing them and still had no luck. I'm not really sure what else I can try at this point.

Share this post


Link to post
Share on other sites
On 5/10/2018 at 9:58 PM, VSteve said:

Hi burgerbait! 

Of course color matched cable wont work.

Long time ago I open up my th8a and drawed a pin assigment. Here you are my attachement. 

58c6a010ada13_Sifterportpinout.jpg.c8a737900d779f644f063ce7ec3efd94.jpg2.thumb.png.47030cad945e9524b056cb0cae54b8d1.png1.thumb.png.40187fbe9f0ad06886f4be005719c731.pngDSC_3128.thumb.JPG.b0f3b7c9286f60e5898a0095409be3c7.JPG

Maybe this helps. If not ask accordingly. 

Steve

 

On 5/10/2018 at 9:58 PM, VSteve said:

Hi burgerbait! 

Of course color matched cable wont work.

Long time ago I open up my th8a and drawed a pin assigment. Here you are my attachement. 

58c6a010ada13_Sifterportpinout.jpg.c8a737900d779f644f063ce7ec3efd94.jpg2.thumb.png.47030cad945e9524b056cb0cae54b8d1.png1.thumb.png.40187fbe9f0ad06886f4be005719c731.pngDSC_3128.thumb.JPG.b0f3b7c9286f60e5898a0095409be3c7.JPG

Maybe this helps. If not ask accordingly. 

Steve

HI Steve, I have the same problem, when I connected the USB cable to the PC, it does not give a life signal. However I opened and checked what colors are connected and to which numbers. I found that brown 9 connects with Gray 8. 

Suppose we're like that? 

IMG_20210210_173327.jpg

Share this post


Link to post
Share on other sites
On 2/10/2021 at 7:56 PM, Vastok said:

I mean that 8 and 9 are bridged. 

Newer mind, wire 9 connected to PS2 port. It's meaning shifter connected to the base. So base know there is on PS2 connector some i2c data from shifter.

Use your multimeter is there 5v usb power?

The shifters send out 3.3V?  There is the 3.3V on microchip controller?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
4 4