Archived

This topic is now archived and is closed to further replies.

Headset audio issues

4 posts in this topic

I hope this is the correct spot for this... I am new to sim iracing,,, wanted a voice chat option. Picked up the Turtle Beach 350VR..

When using the headset I can hear the car, but the chat is still coming through the PC speakers.  I can hear my voice through the mic in the headset just not the other drivers.

I am hoping its a simple setting I am missing somewhere. I searched Google, TurtleBeach, and iRacing forums haven't seen a thread on this issue.

I have gone through iRacing sound settings window and haven't seen anything, the Voice chat is toggled on.  The fact that chat is coming through the pc speakers . Leads me to believe it is a Realtek or Windows 10 setting I am missing. I removed the pc speakers from the Device mgr but no luck...

Running: iRacing, Windows 10, on board sound card Realtek Audio Drivers. Drivers are up to date as far as i know. Any ideas would be appreciated.

Share this post


Link to post
Share on other sites

In the sound settings of Iracing on the chat section did you select your headphones for chat being that the mic is part of your headphones so the mic would not be a seperate device. 

Share this post


Link to post
Share on other sites

If you really want to get rid of the on board audio (Realtek) because you don't use it for anything, then you could go into your BIOS and disable the audio chipset from there.

When you say voice chat, do you mean from the game or from some other program?

The reason you're hearing yourself in the headset is before the mic is set to be listening. In the Sound control panel, go to Recording, select the mic and then properties. Click the Listen tab and uncheck "LIsten to this device" and click OK until you're out.
Although I will say, if there is zero delay, then with a good set of headphones that muffle the outside noises, having it playback in your headset (and hopefully no place else) can be a good thing. I tend to talk a bit louder with my headset on.

Share this post


Link to post
Share on other sites

Thanks for the replies and help.  I figured it out, it was something simple....

On the Sound options page I didn't realize there were drop down menus, I changed all to Realtek and presto....

Some were set to "system default" which was the monitor speakers.

Thanks again for the replies..

 

Nick

Share this post


Link to post
Share on other sites