Archived

This topic is now archived and is closed to further replies.

Help with shift 2

4 posts in this topic

Hi Guys

Im having major problems at the mo.

I have installed the game and it ran lumpy as hell, stuttering etc etc. This was only at the menu too. It was like if something else was running on the computer as well as the game. So i shut it down and tired again and it was the same. TBH I cant remember what I did but I have sorted that now so a i went onto mapping my t500. RIght that done I thought onto the game.

This is where my major issue is, the game is laggy as hell, its as if the game is running at a too high frame rate etc. So i quit out and checked my video settings and they are set on what I deem as ok. no flatout, medium spec. BAck into the career and again the game is stuttering etc etc, it is unplayable!!!

SO thinking i may have a pc issue i went into iRacing and loaded up I went in and exprienced no problem and getting my normal 150fps.

Really dont know what to do now as my pc should run it fine, im using a 5850 card and 3 monitors and dont have an issue with any other game. iRacing, live for speed, f1 2010 all run fine

ANy ideas?????

Share this post


Link to post
Share on other sites

Hi,

This is probably gpu driver and or bad game coding issue ... Same thing happened when Shift 1 was released ... I am running Shift 2 on a hd5870 with 1 single projector at 1920x1080 and I am still having very poor fps at max setting ... I think we will all have to wait for a futur game patch and gpu driver fix ...

- First make sure to install latest catalyst software for your system (v11.3 March 29 2011):

http://support.amd.com/us/gpudownload/Pages/index.aspx

For now you can disable AA in graphic configs ... it will help a lot, but since you are running triple monitors maybe it's not going to be sufficiant and you will also need to lower the other graphic options...

I am getting good fps with these low graphic settings in graphicsconfig.xml file located in yourdocuments\Shift unleashed 2.

Set the resolution according to your monitor settings and refresh rate...

For the wheel settings as I am pretty sure it's running like crap on your system too set it this way:

On the wheel:

Degrees of rotation = 900

In Game:

Steering sensivity = 25

Wheel lock = 50

Hope it helped

Bleco

Share this post


Link to post
Share on other sites

I had the same problem but talk to EA and they helped me out over time. I have triple screen and 2 ATI 5850's in mine. Right now you cant run it in crossfire or you get major slow down. Turn crossfire off. second they had me down load the 11.4 ati drivers from this site http://www.gamebrood.com/2011/03/30/nee ... -and-more/

Also in game turn off all the filtering to start with then work on turning some on in stepss to see how much hit your system can take. I have a fast machine and i still have all filters off to play smooth. this game eats power!!! try this and let me know how it works for you. :D

Share this post


Link to post
Share on other sites

I had the same problem with stuttering but now I am playing with everthing maxed except AA is at 8AA as I recall and zero stuttering and running smooth as a baby's butt...What kept stuttering and locking up I believe to be my t500 and its 1080 degrees...I set too 900 and have had no stuttering or lock ups ever since...keep in mind I do have an extremely fast machine for the graphics so you may need to play around with that and I also use nvidia with softth 5760x1080. So you may be having some ati issues as well dunno.

Well good luck

Blink

Two intel 5650 hex cpus Liquid cooled

Evga Sr-2

24g kingston ddr3

2 crucial c300 SSD 128G in raid 0

2 intel x25 SSD 80G in raid 0 (diff array)

Ultra 1600 watt psu

Evga gtx 580

Evga gtx 470

Lian LI pc-p80r (ya ya i know nvidia sysem in an ATI case)

52", 27", and 3 24" monitors (long story)

Thats it for now...build still in progress

Share this post


Link to post
Share on other sites