Archived

This topic is now archived and is closed to further replies.

G27 problems... Need help!

2 posts in this topic

Hi,

I recently bought a logitech g27 but for some reason i cant get the clutch to work... I have been looking around the internet for hours but cant seam to find any fix for it...

I have installed logitech Profiler (the latest version ofc) and when i go to properties to test everything the clutch meter only engages when i press the accelerator and not when i press the clutch... The accelerat indicator also moves whit the cloutch meter

I have tried to reinstall logitech profiler several times trying it in compatible mode whit w7, i have tried to get the w7 drives and I recently installed a second os (Win7) to see if it would work but it didnt...

Has anyone had similar problems?
Im currently running win 10 and win7 as a second os. i might try to make a clean instal of win 7 to see if that might work.

Share this post


Link to post
Share on other sites

hello it seems that maybe some wires are inverted

it is possible the seller iverted the pedals before selling to you . sometime people mod the pedals

i have the feeling that s the case . Find a tuto on the internet and open and invert the pedals 

also,

if you configure in the game it should be fine as long as you define you own setting no logitech's. the game sees potentiometers . do a custom profile (that s to say your own settings)

 

thanks

 

Share this post


Link to post
Share on other sites