Archived

This topic is now archived and is closed to further replies.

T300rs centering

4 posts in this topic

I just picked up a thrustmaster t300rs to use with this game and I have been having a very hard time with centering. I center the wheel before starting the game and all is good. I skip the practice session and go straight to qualification. At this point the wheel is still centered. As soon as the race session begins, the wheel is no longer centered. I must press the PS button and center the wheel in the menu before going back into my race. Anyone else experiencing this issue? Unfortunately F1 is the only game I have for the moment since I wanted to see if I enjoy the t300rs enough before purchasing project cars.

Share this post


Link to post
Share on other sites

Funnily enough I had a very similar, if not identical issue last night on ProjCars with my T300. I was in a practice session in the Formula Rookie championship at Sonoma raceway and my wheel just seemed to get more and more off centre (to the left) as the session went on. I ended the session with the wheel about 35-40 degrees off centre. It's the first I've noticed it s happen (wheel is about 7 months old) and I've yet to do the quali session, or anything else with it so I don't know if it's an isolated incident or not but I was very interested to see this thread and will be keeping a close eye on my wheel (and this thread too) over the coming days!

Share this post


Link to post
Share on other sites

I think my wheel is defective. I have been unable to get past the calibration phase on my pc and when I connect it to my ps4 it just keeps turning left to right and then stays in a stutter mode and never ends. The PS4 doesn't even recognize it anymore. I've update the latest firmware and everything. I sent an email to Thrustmaster to see what they say but right now I'm leaning toward my 30 day refund.

Share this post


Link to post
Share on other sites

i have heard the latest firmware throws the wheel of centre, need to recalibrate the centre again its in the online manual thrustmasters website. i had the same issue.

Also is the somewhere on this forum where it has some T300 setting for F1 2015 ones have now are shocking!!! unusable!

Share this post


Link to post
Share on other sites