Archived

This topic is now archived and is closed to further replies.

Accuforce and Non supported wheel fix

52 posts in this topic

I'm glad to see that AF owners don't have to go through these steps anymore.   My wheel was detected straight away with the latest version 1 of Dirt Rally and I was off and racing in 2 mins!

Avenga would you be so kind to share me your FFB settings for Dirt Rally, both SC4 and in game.

 

 

Share this post


Link to post
Share on other sites

Yeah, It is great that they finally added full support for the Accuforce.

I haven't played Dirt Rally since I wrote this fix so I haven't played around with the FFB settings.

I am sort of over Codemasters games at the moment so I am taking a little break from them. They do my head in and I have spent so much time sorting out all there controller issues.

One of the guys over on the SimXperience forum asked me to do a fix for the rest of the codemasters games, I have a full F1 2015 fix in another thread but this should pretty much cover them all, the only one I don't have is F1 2014. If anyone needs any more fixes then let me know

Here are some of my findings.

Grid 2

Did I get it going: Yes

What is wrong with the controller support: It suffers from the same problem that Dirt Rally did on launch. You can't adjust the deadzones for the steering axis and it thinks that the Accuforce is a game pad

Workaround: Basically it is the same as my early Dirt Rally fix but to make it easier just open any of the wheel XML files in ..\SteamLibrary\SteamApps\common\grid 2\input i.e lg_driving_force_gt.xml and replace the device type with 804C1FC9-0000-0000-0000-504944564944 Then go to the controller options in the game and select presets and you should see the preset for the wheel that you modified the XML for. Then reassign your pedals and shifters etc. DO NOT touch the steering axis after you apply the preset.

Recommend Degrees of Rotation: about 280-360 feels good 

What didn't work: Like in my early Dirt Rally fixes, you can't use an H pattern because it thinks you are using a game pad

Does Game FFB work: Yes it works, feels a little heavy and dull but it works. SimX FFB felt a bit wobbly.


Grid Auto Sport

Did I get it going: Yes

What is wrong with the controller support: It suffers from a similar problem to Grid 2. It thinks that the Accuforce is a game pad But You CAN adjust the deadzones for the steering axis, this means no XML hacks are needed

Workaround: go in to the controller options, bind your steering axis then go in to advanced options and remove all the deadzones

Recommend Degrees of Rotation: about 280-360 feels good 

What didn't work: Like in my early Dirt Rally fixes, you can't use an H pattern because it thinks you are using a game pad

Does Game FFB work: Yes it works, feels a little heavy and dull but it works. SimX FFB felt a bit wobbly.

F1 2013

Did I get it going: No

What is wrong with the controller support: While it looks like it should work because you can override the controller type. I couldn't get my pedals going and the FFB was just stuck on 100% center spring, could hardly move the wheel

Workaround: I haven't found one just, I will work on it some more. I know it used to work because I remember racing with one of my friends during the Accuforce beta test. (At the time I couldn't tell him I had an Accuforce because I was still under NDA but he was wondering why I all of a sudden started kicking his ass:) ) From memory I was using SimXperience FFB back then.

Recommend Degrees of Rotation: Not sure yet

What didn't work: Pedals and FFB

Does Game FFB work: No, Locked on center spring

Dirt Showdown

Did I get it going: Yes

What is wrong with the controller support: It is not supported by Sim Commander due to bugs which cause it to crash when you enable motion so you need to save the settings you want to the wheel itself.

Workaround: Got the the Sim Commander control center > settings > Sim Device Manager then Accuforce. Set all your rotation settings etc in there then click save to controller. Then go in to the game and set up all the control axis, then go in to the advanced options and remove the deadzones

Recommend Degrees of Rotation: about 280-360 feels good 

What didn't work: Sequential gears, I couldn't find how to change it from auto to manual sequential.

Does Game FFB work: Yes, but it felt pretty heavy and a bit snappy, you would probably want to turn down the strength in Sim Commander

F1 2014

I don't have a copy of F1 2014 but if anyone wants to gift me a copy via Steam then I am happy to have a go at getting it going. Chances are pretty good that I will be able to find a workaround. I am getting pretty good at figuring out how to get the controllers going in codemasters games now.

Share this post


Link to post
Share on other sites