Archived

This topic is now archived and is closed to further replies.

g27 only detected on pc when brake pedal is pressed

13 posts in this topic

the g27 turns off and when i press the pedal down again it does its startup calibration,ive narrowed it down to a issue with the pedals as it only does this when they are plugged in

Share this post


Link to post
Share on other sites

Sounds like some kind of short circuit or faulty wiring! 

If its under warranty I suggest you RMA it.

If not, you could open up wheel and pedals and check the wiring. Start with the pedals.

Share this post


Link to post
Share on other sites

This happens when you used for example usb without power on it. Try different usb ports. In windows in control panel there was option to do not stop power for usb ports. Windows have by default sometimes to stop power after some time. 

This is not from the G27 I am 90% sure.

 

The strange thing I found that when you have prob witht he USB  - only the brake pedal haver the power to show this problem. It`s like the brake have some strong impulse;)

 

First time when I read your post I didnt understand the issue - I saw it like on PC brake stays pressed nonstop- it was late here and I was sleepy;)

Share this post


Link to post
Share on other sites

That confirms my guess it is related with the USB , it can be related with drivers (not nessesary  USB problem) But the wheel is OK.

 

I have same thing many times with my Fanatec wheels with G27 pedals with adapter. Brake reconnected the wheel nonstop.

 

Once this helps me:

 

I went to Device Menager and you will see the uSB host controllers or something installed int he list with device. I did uninstall to all. PC will install them again automatically or just give refresh. after the new installes USB host controllers the problem was gone.

 

You need to try some things to resolve this , because it is not from the wheel. And we are here to help.

 

After reinstall all USBs on unplugged wheel ofcourse - on the wheel remove power.... and after that put power and plug it in the PC. If you did everything right - Windoes must install it again like new device.

Share this post


Link to post
Share on other sites