Archived

This topic is now archived and is closed to further replies.

rfactor 2

7 posts in this topic

Hi. Anyone having problem with rfactor 2 startup? I have reasently purchased it, and when i finished downloading and install, i registered my account. I start the game, and Windows shut it Down. Happens everytime. I tried uninstall and install it again but something is missing. My PC should bi powerful enough. Anyone??

Share this post


Link to post
Share on other sites

And it's why people like Steam. These little companies really do a lousy job with DRM. ISI had an episode months ago where they accidentally lost a ton of rf2 accounts from their system. And you had to manually send them a copy of your purchase e-mail and account info so they could re-establish your account for you. And then there's Reiza and their activation limit. Which is bad enough, but then they ignore e-mails and only respond if you know enough to post a message in the GSC thread over at racedepartment forums.

Share this post


Link to post
Share on other sites

Not quite sure how/if DRM is related to this... 

 

When you open the launcher and you have signed in, is the little icon "connected" green and the large pic in colour?

Actually, can you open the launcher itself?

Does the program crash as soon as you click single player, or multi player, or when?

 

I'd actually try to go to the ISI-forum, there people know rF2 :) but some more info might be needed to get a good reply? 

Share this post


Link to post
Share on other sites

I have green icon yes. And it does crash when i both single player and multiplayer. I got some help last night in another post i wrote. But im still waiting for my email from rf, cause i uninstall the whole thing, and need a renewal. :) but if you come up whit something, let me now. Thanks :)

Share this post


Link to post
Share on other sites