Archived

This topic is now archived and is closed to further replies.

G27 Problems Nooo!

6 posts in this topic

Hi users, today I was ready to go and do some F1 2013, but when I turned my PC on, my G27 wouldn't calibrate. The green light went on, but nothing happened :( Anybody know how to fix this? BTW my pedals and shifter work perfectly well, but my wheel is dead...

 

 

>Cheers!< Jrv01

Share this post


Link to post
Share on other sites

How did you make out?  If the green light on the shifter is dim, its not getting proper power to the wheel.  Check as stated in above post and make sure the breaker did not trip where the power adaptor is plugged into the wall.  If the light is bright you have bigger problems.  Check on You Tube.  I found the solution to my steering wheel losing center because of 2 screw being loose on the optic sensor board mounts.

Share this post


Link to post
Share on other sites

How did you make out?  If the green light on the shifter is dim, its not getting proper power to the wheel.  Check as stated in above post and make sure the breaker did not trip where the power adaptor is plugged into the wall.  If the light is bright you have bigger problems.  Check on You Tube.  I found the solution to my steering wheel losing center because of 2 screw being loose on the optic sensor board mounts.

 

There was some kind of a problem with the actual plug that the wheel was plugged to. I ended up getting it work nicely again :)

 

 

>Cheers!< J.A.R.V.I.S.

Share this post


Link to post
Share on other sites