Archived

This topic is now archived and is closed to further replies.

G27 blocked

10 posts in this topic

Hi all,

 

I have a issue with the wheel, actually when i go to game controller settings and proprieties my wheel is set to 200° by defaut and when i turn the wheel the movement test wheel on my screen move coordinately with mine, until here all is fine.

 

Now when i click to parameters to set it at 900° then the movement test wheel doesnt turn coordinately anymore, for example when i turn to 180° the screen show only 45°.

 

Also everytime i quit the test window my wheel block immediately and i can't turn it anymore left or right. It unlock only if i enter to the test window screen.

 

I've also try to parameter my wheel directly from iracing but my wheel is still blocked.

 

Anyone have any idea why all this happend ?

 

Thanks

Share this post


Link to post
Share on other sites

Thanks for reply but didnt change :(

 

Actually my wheel is locked at 10°, because when i move the wheel with those 10° rotation from left to right the visualization wheel in option in iracing make a 900° flip left to right :/

 

So i can't understand why when i quit the logitech test window my wheel lock to 10°... :s

Share this post


Link to post
Share on other sites

the first thing that you can do is to uninstal complete drivers and logitech profiler

unplug the wheel

restart system power the wheel to the wall and then plug it to different usb

windows will recognise it ... after that you can install logitech software

it sounds like drivers are messed up

Share this post


Link to post
Share on other sites

hey krassi,

 

 

i try all this but nothing, here is a message i just wrote to logitech forums and i try to explain it a bit more clearely.

 

here is the message :

 

I actually have an issue with my wheel.

 

When i plug the wheel tothe usb connector the wheel calibrate normally but when it finish it lock at 10° rotation.

 

Then
when i go to the test window screen in the controller settings and
properties the wheel suddenly unlock to the default  200° rotation and
when turn my wheel it's coordinate with the wheel movement on the
screen.

 

Now when i go to the parameter window to set a
different rotation my wheel lock again at 10°... so i set 900° rotation
close the window to return to the test window screen and my wheel unlock
again.

 

So my wheel can unlock only when i'm in the test window screen and whenever i close it my wheel lock to 10°.

 

Also
after have set the 900° rotation and i turn my wheel, now the wheel
movement on the test window screen is not coordinate anymore. So for
example when i turn my wheel to 180° in the screen it show only 45°.

 

I have follow all installation instruction,uninstall/reinstal, try different usb port but the problem is still there.

Share this post


Link to post
Share on other sites

Maybe you dont have another netbook or game system to check on it... do you have DXTweak?

 

It is a small software that can show you the axes of your wheel like numbers and you can set it properly

 

If you dont have it gimme your email I`ll send it to you .

Share this post


Link to post
Share on other sites

If it`s not something in the windows register the other option is the optical sensor on the wheel.

Sometimes the plastic encoder wheel makes problems, the easiest case will be if only the screws on the optical sensor are loose. 

Share this post


Link to post
Share on other sites

Maybe you dont have another netbook or game system to check on it... do you have DXTweak?

 

It is a small software that can show you the axes of your wheel like numbers and you can set it properly

 

If you dont have it gimme your email I`ll send it to you .

i don't have dxtweak indeed, also i plug the wheel inmy notebook and the wheel lock at 10° after calibration again. Note that logitech profiler wasn't install on the notebook.

 

About dxtweak i found it i'll try to see what i can do with.

 

Actually i wonder if i didn't screw up something in the motherboard of the g27 by myself.

 

I say this because i add buttons to my wheel and i remember that while i was making the wiring connection i accidentally make touch buttons wires between them and then the wheel make a flip like when you test button in control panel but then i remember that the logitech software had crash.

 

I don't know if is this thing that make this trouble right now...

Share this post


Link to post
Share on other sites

ok, i've been able to make the wheel work perfectly on live for speed. I launch it from the profiler.

Problem is now with iRacing, i can't launch it from the profiler and when i do it by the site my wheel is still locked..

Do i have to setup iRacing in a particular way in the profiler ?

Share this post


Link to post
Share on other sites

Problem solved, i quote my own message in case someone have the same issue someday.

 

"Actually i found out the problem, it was due to the center spring strenght set to 100% by default.

Now i set it to 0% and i can turn the wheel without Popeye arms.

What make me turn around is that when i was launching other games
the center spring strenght disabled by itself at splash screen and then i
was able to configure my wheel normally.

But on iRacing the option was still enabled and i couldn't move it normally to configure it.


I actually don't know if it's a normal process or not but it's look kind of weird."

Share this post


Link to post
Share on other sites