Search the Community

Showing results for tags 'loud fan'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Most Popular
    • Getting Started In Sim Racing
    • Sim Racing Discussion
    • Sim Gear - Buy and Sell
    • Simulation Racing Rigs / Cockpits
    • Wheel & Pedal Set Discussion
  • General Discussion
    • Inside Sim Racing Discussion
    • General + Real World Racing Discussion
    • Sim Racing Paint and Photo Shop
    • Sim Racing Videos
    • Other Gaming
  • Sim Racing Hardware
    • Audio Related
    • General Hardware Questions
    • Motion Hardware and Software Discussion
    • PC (Personal Computer) Gaming System
    • Peripherals
    • Playstation Discussion
    • Sim Vibe Hardware and Software Discussion
    • Video Related
    • Virtual Reality
    • XBox Discussion
  • Racing / Driving Games & Simulations
    • Assetto Corsa
    • Automobilista
    • Codemasters Dirt Series
    • Codemasters Formula One Series
    • Forza Motorsport Series
    • Gran Turismo Series
    • iRacing
    • Live For Speed
    • Moto GP Series
    • Project CARS 2
    • Project CARS
    • Raceroom
    • rFactor 2
    • rFactor
    • Richard Burns Rally
    • RIDE the Game
    • SimBin Studios
    • The Crew
    • WRC Series
    • General / Other Software
  • Website Discussion
    • New Website Development
    • Website Bugs
  • Archive of old sections
    • ISR Archive
    • Jessica Lopez
    • Opinion Nation
    • SSCA - Simulated Sports Car Association
    • Sim Racing League Hub
    • Top Simulation Cars of All Time
    • Throw Back Thursday

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Hi everyone. So i was finally able to test my new T300 RS and i have a big problem with it and i would love to hear your opinions. Is T300 RS supposed to be extremely loud? Mine is loud as airplane starting. I have very powerful gaming PC with lots of fans and the PC is completely quiet when compared to the crazy noise the wheel is doing. I almost don't hear the game even though i have headset on. Before buying i have read that this is very quiet wheel and it has very quiet force feedback etc but nobody ever mentioned how crazy loud the fans are (i guess the noise must be fans or something). I think this would probably wake up the neighbours even. Is it normal with this wheel? I've seen some topics where people are replacing the fans on this wheel so i guess it is common problem? Or is mine faulty somehow? I don't have a recording but there is a video on youtube, where someone has the same problem (even though mine is even louder than his) : https://www.youtube.com/watch?v=YMNV2EtjbfA Oh and i should mention that my force feedback is not even set that high. I have it on 75 % in Control Panel and on reasonable levels inside the game. Return it or every T300 is that loud? Thank you guys (one other thing that may be connected to it - calibration doesnt work. It always centers the wheel like 20-30 degrees off the center. I have to manually calibrate it each time, do the three button manual calibration save, and if i want to use the wheel again, its again not calibrated and i have to do everything again and again)