• Upcoming Events

    No upcoming events found

Getting Started In Sim Racing
16 16

This area is devoted to those that are Getting Started in Sim Racing. Ask whatever questions you need to here !

778 topics in this forum

    • 687 replies
    • 69,571 views
    • 21 replies
    • 13,536 views
    • 0 replies
    • 9,798 views
    • 0 replies
    • 53 views
    • 2 replies
    • 346 views
    • 0 replies
    • 93 views
    • 0 replies
    • 262 views
    • 0 replies
    • 45 views
    • 0 replies
    • 103 views
    • 0 replies
    • 31 views
    • 8 replies
    • 1,323 views
  1. Need Help

    • 0 replies
    • 80 views
    • 0 replies
    • 23 views
    • 0 replies
    • 51 views
    • 4 replies
    • 818 views
    • 1 reply
    • 734 views
    • 0 replies
    • 208 views
    • 0 replies
    • 883 views
    • 1 reply
    • 649 views
    • 0 replies
    • 596 views
    • 0 replies
    • 436 views
  2. deleted

    • 0 replies
    • 418 views
    • 0 replies
    • 440 views
    • 1 reply
    • 633 views
    • 1 reply
    • 601 views
16 16

Announcements



  • Posts

    • Small midge OSW with Heusinkveld Pro 3 pedal set. Mounted to custom and adjustable homemade 8020 rig. Comes with Thrustmaster shifter, Richmotec PTT and button box with ram mount. $2800. Will consider separating and shipping the wheel and pedals at buyers expense. These items are heavy.  Local pickup only for the whole thing . Text 8286741418 if interested.     
    • I really love my Chromebook, I’ve had it for five years when I only expected it to last for two max. But its not Android compatible and I would really love to emulate some games (PSP) and run Steam. Im looking to play things like Stardew Valley and old school PC games fyi. I would like to not spend a lot (over $400ish) I went through the lists of comparing laptops, but I’m really not super familiar with computers and which brand is best. If this isn’t possible then I will just go PC but I’d rather stick with Chrome.   GUys m watching this video - 5 Great things about Chromebook
    • So this isn't strictly an nbn problem but I couldn't really find an appropriate subreddit anyway I got nbn a week or so ago and it's working fine and I was using the 5ghz wifi on my devices but all of a sudden today I come home and my iPhone doesn't connect to the 5ghz. It auto connected to the 2.4 as expected but after manually selecting 5ghz it loaded for a while in settings and then just said unable to connect, so I forgot the network and when I tried to join again I entered the pw correctly n it said incorrect password after 30 seconds and I clicked dismiss, pressed join again and it said unable to join over and over. I am able to disconnect and reconnect perfectly fine on my other devices, just my phone won't connect to the network for more see this    
  • Topics

  • Popular Contributors

    Nobody has received reputation this week.

  • Who's Online (See full list)

  • Member Statistics

    • Total Members
      37,676
    • Most Online
      2,028

    Newest Member
    SpencerGaf
    Joined
  • Recently Browsing

    No registered users viewing this page.